Enabling AHCI Mode

These instructions assume you have Windows already installed and configured in IDE mode and want to change to AHCI mode, without reinstalling.

1) Load Windows in your current configuration and run Registry Editor (regedit.exe).
2) Navigate to Registry Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci or HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\lastorv (whichever exists).
3) Set the Start value to 0 (zero).
4) Navigate to Registry Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\pciide.
5) Set the Start value to 3 (three).
6) Shut down and restart.
7) Go into your motherboard's BIOS configuration and change the SATA mode from IDE to AHCI. Save the new BIOS configuration.
 
Windows will detect the new controller and install new drivers. After installation you will be prompted to reboot.

NOTES: These instructions are not applicable to Windows XP as it has no native AHCI support. You would need to provide drivers (if they exist) for your specific motherboard. This guide is intended for Windows Vista and beyond.

When activating AHCI mode you may need to rewire the power to your OS drive. Our earlier FRED systems (that had Firewire Hot Swap bays) will probably have the OS drive sharing it's power connection with one or more Hot Swap bays. If this is the case the OS will detect a power change on the line (when a Hot Swap bay is powered on) and will Blue Screen the system as a data protection feature. Another device that could share the OS drive's power line is the USB hub at the top of the system. Some external USB HD's will draw enough power to cause this same behavior. The only solution is to have the OS drive's power line isolated from any other power pulling devices.

Once you've successfully converted to AHCI mode you may notice that SATA and IDE hard drives don't appear to be write blocked on an UltraBay II. You're seeing this due to the design of the SATA drivers, they don't report a write blocked state like the old Firewire connection did. As a test, go ahead and create your folders/files on a drive connected to the UltraBay II. Then power cycle the UltraBay II with the drive still attached and you'll see that nothing has actually been written to it. Windows caching is what was being displayed.